Back to overview
Maintenance
Athena V2
Oct 18 at 12:00am BST
–
Oct 18 at 11:59pm BST
Affected services
Discord Bot
Resolved
Oct 18 at 12:00am BST
Athena will experience downtime while we integrate Version 2.0
Affected services
Resolved
Oct 18 at 12:00am BST
Athena will experience downtime while we integrate Version 2.0
Affected services